Mon, 9 Jul 2001 14:25:11 -0500
I very much like the idea of having the resource limits available, but I
really don't like the names of the resource datatype constructors. I see
that they are taken exactly from the getrlimit/setrlimit, and that is enough
of an advantage that it is best, but, as an example, the NO prefix of NOFILE
and the N prefix of NPROC both stand for the same thing.
Along the same lines, perhaps the hard and soft should be called `cur' and
`max'? Also, you need to have RLIM_INFINITY.