[MLton] cvs commit: mlb annotations quoted
Wed, 3 Nov 2004 11:21:58 -0500 (EST)
> > > ann
> > > "deadCode true"
> > > "sequenceUnit true"
> > > "warnMatch true"
> > > "warnUnused true, forceUsed"
> > > in
> > >
> > > That seems easier to read and write than the backslashes.
> > Who should put in the delimiters? That is, should the sequence be
> > concatenated with ","
> No, each annotation should be parsed and elaborated individually, in
> sequence, just as with multiple -default-ann command line arguments.
> I guess this has the same effect as automatically putting in the ",",
> but I think it is a simpler way to think about it.
> > I actually prefer the single string constant.
> MLton mailing list